728x90
BOJ 2407 조합
문제
시간 제한 : 2 초
메모리 제한 : 128 MB
입력
n과 m이 주어진다. (5 ≤ n ≤ 100, 5 ≤ m ≤ 100, m ≤ n)
출력
예제 입력 1
100 6
예제 출력 1
1192052400
풀이
# boj 2407 조합
import math
n, m = map(int, input().split())
numer = math.factorial(n)
deno = (math.factorial(n-m)) * (math.factorial(m))
print(numer//deno)
728x90
'Algorithm(Python) > 수학' 카테고리의 다른 글
[Algorithm] 백준 BOJ 1748 수 이어 쓰기 1(python 파이썬) (0) | 2023.04.21 |
---|---|
[Algorithm] 백준 BOJ 15964 이상한 기호(python 파이썬) (0) | 2023.04.20 |
[Algorithm] 백준 BOJ 5554 심부름 가는 길(python 파이썬) (1) | 2023.04.18 |
[Algorithm] 백준 BOJ 2338 긴자리 계산(python 파이썬) (0) | 2023.04.17 |
[Algorithm] 백준 BOJ 5565 영수증(python 파이썬) (0) | 2023.04.16 |