728x90

BOJ 11051 이항 계수 2

문제

시간 제한 : 1 초
메모리 제한 : 256 MB

입력

첫째 줄에 N과 K가 주어진다. (1 ≤ N ≤ 1,000, 0 ≤ K ≤ N)

출력

예제 입력 1

5 2

예제 출력 1

10

풀이

# boj 11051 이항 계수 2
import sys

input = sys.stdin.readline
n, k = map(int, input().split())
res = 1
for i in range(k):
    res *= n
    n -= 1

div = 1
for i in range(2, k+1):
    div *= i

print((res // div) % 10007)
728x90

+ Recent posts